Graphical Data Processor (GDP)
User Manual

L= aLx
-18] |
=2 ?
Praject Informatlon] Aggregatlon] EditData Data Availability ] Unitz Page
Stat. [dan =] [t =] gm0 =] Bzt o= e 5=
" Single Station, Multiple Parameters ' Data Availabilly
End: |DBC ﬂ |31 j . |1888 ﬂ % Multiple Stations. Single Parameter f* DataValues
Main list consists of (% Stations " Parameters
. Plot Style Interval
Stations Parameters T
o Lot
~| [WalER TEME High-Low-Close Every
07051800 & Median ’—L|
07082000 — [LE&D PE_TOT ears
07022400 LEAD PB_DISS [ Add threshold line at:
07022500
i 5TREAM FLOW X
07083500 = = [o]
07083700 =

| 9 | 5o 12 2] | ]| ] ] lzE| o3[ /] 2]Q

Diata for parameter STREAM FLOW

Station [171970 (17197 STREAM FLOW
N EEEE 7]
07083000 213 249696 e

a7

.1

INST-CFS

|

B - -
Ready

Version 1.1

Developed by the Integrated Decision Support Group (IDS) at Colorado
State University for The United States Bureau of Reclamation and the
Environmental Protection Agency (EPA).

AT Cogg'édo 0o s

Environmenta
=— - Protection
SLUreay oF pecLMATS University Agency




Graphical Data Processor (GDP) User Manual Version 1.1

Copyright
Copyright © 2000Integrated Decision Support Group
601 South Howes, USC Suite 502
Colorado State University
Fort Collins, Colorado 80523 USA

About This Document

This document is a user manua for the Graphica Data Processor (GDP) software developed as an
analysis aid for the Water Quality Analysis Simulation Program (WASP) Version 5.0. Thisuser manual is
paralel to the on-line documentation available from the software. In addition to this user manud thereisa
programming routine manual that documents the system’s current capabilities and describes each of the
programming routines developed for this projed.

Participation

This project was sporsored and directed by the Department of Interior Bureau of Reclamation
(Redamation), the Environmental Protection Agency (EPA) Office of Science and Technology, and the
Integrated Decision Support Group (IDS Group) at Colorado State University (CSU), Fort Collins,
Colorado USA. Faculty, staff members, and graduate students from the IDS Group and the Department of
Chemical and BioresourceEngineeringat CSU served asthe principal investigators. IDSispart of the Water
Center at Colorado State University in Fort Collins, Colorado, USA.

For more information contact:

LuisGarcia- IDS Group Merlynn Bender -- USBR

Colorado State University Denver Federal Center - Building 67

601 South Howes, USC Suite 502 Box 25007 Mail Code D-8570

Fort Callins, CO 80523USA Denver, CO 80225USA

Phore: (970 491-5144 Phore: (303 4452460

FAX: (970 491-2293 FAX: (303 4456351

E-mail: garcia@engr.ColoState. EDU E-mail: mbender@do.usbr.gov
Acknowledgments:

Services, cooperation, effort, information, reviews and guidance provided by Reclamation and EPA
staff aregrealy appreciated. Spedal thanksto Merlynn Bender (Reclamation, Denver, CO) and Dr. Russdll
Kinerson (EPA, WashingtonD.C.). Dr. Luis Garciawasthe Principal Investigator and drector of the project
at the IDS Group (CSU), David Patterson and Hong Zhaohui did the programming and software
engineering, and Robert Lange and Anna Perea creaed the documentation.



Table of Contents

Table of Contents

1.0 INtroduction - - === c oo s o e e e 1
1.1 Hardware Requirements ------------------mmmm oo 1

1.2 WASP BUIIAES - = - - = = = = = o m e e e e e e e e e e e e 1

1.3 WASPVErSIONS - -----mmmmmmm e e oo 1

1.4 STORET DaaFiles - == - === == m o m o e e e e e 2

1.5 WATSTORE DataFiles --------------mmmmm oo 2

2.0 Getting Started With GDP = = - = - - = - - m oo e e e o s 5
21 InstalingGDP = === == - ccceecmcc e e 5
2.2 Starting GDPinWindows - - ------------mmmmmm oo 5
Creatinga New Project - - - - - ---------mmmm oo 6
Loading Parameter Data - - ---------------cococ oo 6
Selecting Multiple ltemsfromalList - - - ---------------mmm e 7

3.0 Pull DOWNWiNdOWS - - - = = == == - oo oo oo oo 9
31 FileMenu ------------mccmmmcc i dc e n e mc e m e - 9
NEeW Projects - - - - === oo o e e e e e e oo 9
Opening Projects - - === - - - o mmmm e e oo e e e 9
ClosingaProject ----------cmmmmm oo 9

Saving aProject - - - - - - - - - 9
Selecting Other Projects - - --------cmmmmmmm e 10
Exitingthe Project ------ccccmmmmomom e i e e e eeee e 10

32 DataMenu =------cmeee e e 10
Adding Data froma Soreadsheet - - - - === -----------mmmm oo 11

3.3 View Pull-Down Menu - ----------mmmmmmmm oo 12

3.4 Window Pull-DOwNnMenu - - - - === === --mm e oo 13

3.5 Help Pull-DownMenu - ----------mmmmmm oo 13
GDPHEp ---- - mmmmmmm e o 14

ADOUt GDP - - - e e e e e oo 14

40 DataTabs ---- - oo e 15
4.1 Project Information Tad - --------------““---c oo 15
4.2 Aggregation Tah - --------------mm oo 15

R T = 14 0 = - e 17



Graphical Data Processor (GDP) User Manual

Adding and Deleting Sation-Parameter pairs. ------------------------------
Adding Valuesfor Parameters ----------------------mmmmoo oo
4.4 DataAvailability Tab -----------------omm e
Data TimePeriod ~----------c---cocmacc i ccce e mec e cmc e nm e o e -
MainList Setting -------cccmmmmmoce e e e e e me e
Station and Parameter ListS - - - -------------------o oo
DataDisplay ==-=-------ccccmmmmmee et e e e e e e et e
DataType ------------------ oo
Graph Button - - --------cc-c-cccmm e ncccmcccc e ccc e m i mae oo
Export Button - - - ---------------- -
Exporting Data for WASP - ---------mmmmmmm e
o S Y R e
Datelnterval -------c-ecmcmmmme et i e e e e e m et e s
Interpolate Option --------------c-c-mccmmccc e rec e ne e e

45 UnitsPageTah - ---------cmmmmmmm i oo

50 Input FileFormats ------- oo oo oo oo
5.1 STORET FileFormat - ----------m - m o e e
52 WATSTORE FileFormat - -----------------“-“-“-“-“-“+«--oaaa oo

6.0 REfErenCes - - - - - - - - o - oo oo
A B 1o [ e i e

GDP Version 1.1 iv



Introduction

1.0 Introduction

Current methods for preparing input files for water models such as WA SP5 are cumbersome and often
become the mgjor task of water modeling projects. The Graphical Data Processor (GDP) has been designed
to receive standard inputs from STORET, WATSTORE, and spreadsheets. GDP can be used to interpolate
datafor time periods and can be used to combine parameters and/or stations so that they appear as asingle
entity. Once data has been processed it can be used with WA SP Builder tofill parameter values such asflow
or constituent amounts, or it can be used for other modeling tasks.

1.1 Hardware Requirements

GDP, the data preprocessor described in this manual, has been designed to run in a Windows 95/98/NT
environment with at least a 486 processor and 16 megabytes of RAM.

1.2 WASP Builder

WASP Builder can be used to build input files for the WASP water quality model. Data developed in
GDP can be imported into WASP Builder to fill out data cards for WASP.

1.3 WASP Version5

Water Quality Analysis Simulation Program (WASP) is a generalized framework for moddling water
quality and contaminant fate and transport in surface waters. Based on a flexible compartment modeling
approach, WASP can be applied in one, two, or three dimensions. WA SP is designed to allow substitution
of user-written routines into the program structure. Problems that have been studied using the WASP
framework include biochemical oxygen demand and dissolved oxygen dynamics, nutrients and
eutrophication, bacterial contamination, and organic chemical and heavy metal contamination (EPA, 1995).

WA SP has been used to simulate the water quality and pollutant fate for avariety of aguatic systems. It
isused primarily to investigate the water quality response to management actions, primarily point and non-
point source load reduction. It is presently being distributed by EPA-Office of Research and Devel opment/
Center for Exposure Assessment Modeling Athens, GA (CEAM).

Thetechnical contact is:

Robert B. Ambrose, Jr.

Address: U.S. EPA-Center for Exposure Assessment Modeling
960 College Station Road

Athens, GA 30605-2700

1 Hardware Requirements
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1.4 STORET DataFiles

STORET isa computerized data base utility maintained by EPA for the STOrage and RETrieval of
parametric data pertaining to the quality of the waterwayswithin the contiguous United States (EPA, 1996).
STORET includes several individual but related systems, which contain various types of information:

1

Geographical, political, and descriptive information concerning sites where data have been
collected. These sites, known as“ stations” within STORET, are the baseto which data ae dtached.

M easurements of the physical characteristics and chemical compasition of water, fish tissue, or
sediment sampled at these sites, referred to as “ parametric” datain STORET. This system, the
Water Quality System, is by far the largest and most widely known facility in STORET.

Counts and descriptions of living organisms found at these sites, known as “Biologicd Field
Surveys’ in STORET.

Stream flow data, obtained from the U.S. Geological Survey, in what is cdled the “daily values’
system.

This project has been designed for the types of data found in the Water Quality System, but may be
expanded to include other items. The data contained in STORET are colleded, stored, and used by avariety
of federal, state, interstate, and local government agencies, and their contractors. For more information,

contad:

STORET User Asdstance

Mail Stop 4306-F

U. S. Environmental Protection Agency
401 M St., SW.

Washington, DC, 20460
(800)424-9067
STORET@epamail.epa.gov

1.5 WATSTORE Data Files

The National WATer Data STOrage and REtrieval System (WATSTORE) was established in 1972to
provide an effective and efficient means for the processing and maintenanceof water data llected through
the adivities of the U.S. Geological Survey and to facilitate rel ease of the datato the pubic. A variety of
useful products, ranging from data tables to complex statistical analyses such aslog-Pearson Typellll, can
be produced using WATSTORE. The system resides on the entral computer facilities of the U.S.
Geological Survey at its National Center in Reston, Virginia, and consists of related files and data bases.

Station Header File - Contains descriptive information on more than 440,000 sites throughout the
United States and its territories where the U.S. Geological Survey collects or has collected data.
Daily Values File - Contains more than 220 million daily values of streamflows, stages, reservoir
contents, water temperatures, spedfic conductances, sediment concentrations, sediment discharges,
and gound-water levels.

Peak Flow File - Contains approximately 500,000 maximum (peak) streamflow and gage-height
values at surface-water sites.

Water Quality File - Contains approximately 2 million analyses of water samples that describe the
chemicad, physical, biological, and radiochemicd characteristics of both surface and gound water.

GDP Version 1.1 2
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e Ground-Water Site Inventory Data Base - Contains inventory data for more than 900,000 wells,
springs, and ather sources of ground water. The datainclude site location, geohydrologic
charaderistics, well-construction hstory, and ore-time field measurements such as water
temperature.

In 1976, the U.S. Geologica Survey opened WATSTORE to the public for direct access. The signing
of aMemorandum of Agreement with the Survey isrequired to oltain drect accessto WATSTORE. Dired
acocessmay be obtained by contacting:

U.S. Geologicd Survey
National Water Data Exchange
421 USGS National Center
Reston, Virginia 20192

3 WATSTORE Data Files
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Getting Sarted with GDP

2.0 Getting Started with GDP

GDP providesfunctionsthat allow usersto combine datafrom different sources, to aggregate (combine)
parameters and stations, and to interpolate values at different time increments. The data can be imported
from STORET, WATSTORE, or spreadsheets. Results can be exported to a datafile, spreadsheet, or to
WASP Builder for assembling input files for WASP.

2.1 Installing GDP

1. Inworld wide web browser open the following page:

http://www.ids.colostate.edu/pr oj ects/gdp/download.html

2. Todownload azipped file containing the setup filesfor GDP, click your mouse on the most current
version of GDP listed in the table.

3. After selecting the file in your browser, open the file and use the I nstall button in the Winzip
program.

4. Follow the setup instructions.

2.2 Starting GDP in Windows

1. Select the Programs option from the Start menu on the lower left corner of the screen (Figure 1).

Program Options

Sart Menu

Figure 1: Programs Option in the Start Menu.

2. Oneof theoptionswill be WASP AT. Select the WASP AT folder in the program menu and open
the GDP folder and select the GDPfile.

5 Installing GDP
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3. Thewindow shown in Figure 2 will be displayed.

&~ GDP - [GDP1] [_ O[]
File Data Miew ‘Window Help - & x|
O = ®

-

PTUiECHNfUTmatiUn]Aggregation Edit Data | Data Availability UnitsPage]

Input D ata Files:

-
| »

Feady CAP |MUM

Figure 2: Main Display Window.

2.2.1 Creating a New Project
Y ou can create a new project before you begin working.

1. Tostart or create a new project, select the New option from the File menu.

2. Select anew name and save the file. GDP files have a*.gdp extension.

222 Loading Parameter Data

Y ou can select STORET, WATSTORE, or spreadsheet files for analysis using the Data > Add
STORET or WATSTORE format or the Add from Spreadsheet option. GDP currently requires
STORET and WATSTORE files to be in the standard format and text files to be in supported formats (see
Section 5.0: Input File Formats).

When GDPisinstalled adirectory called Examplesiscreated that contains example datafiles. The path
for thisdirectory istypically C:/Program FilessWASP AT/GDP/Examples. To import data from STORET
or WATSTORE follow these steps:

1. Selectthe Data> Add STORET or WATSTORE format option.

2. Usethe Open window to select the directory that contains the data files (Figure 3). If you need to
access another disk to get to your data files, you can change the directory by clicking on the scroll
list next to the Look In field, see Figure 3.

GDP Version 1.1 6
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Look jr: {2 examples ﬂﬂgl
= 3% Floppy [&) =
&= Fall[C)
(Z Program Files J
1 105 Group
3 Gd
Ee koxamples]
&= Fall D7) i i i
= ) _ Click here to change directories.
File name: I"S2E95AD.txt" "'metalsw. sta" DOpen I
Files of type: [l Fies () = Cancel |
[ Open az read-only

Figure 3: Selecting Directoriesin the Open Window.

3. TheFilesof typefield showsthe extensions of each file type. Figure 4 illustrates the extensions
asociated with STORET and WATSTORE.

File name: | Gpen | Click here to show filter options.

Files of type: [l Files [+)

[STORET and wATSTORE files ~.sto, “wat) |
STORET files [*<to)
WATSTORE files [*wat]

Figure 4: Showing Particular File Typesin the Open Window

e STORET filesmust have a“*.sto” extension.
« WATSTORE fileshave a“*.wat” extension.

Select filesindividually by holding davn the left mouse button and the Control key. Hold down
the left mouse button and the Shift key to select groups of files.

e

5. After seleding thefiles, click onthe Open button.
3

2.2 Selecting Multiple Items from a List
By using the shift and control keys multiple items from alist can be selected.

e Control Key - The control key is used to select multiple itemsthat are not listed in series. Depress
the control key and select the desired items with the mouse.

« Shift Key - The shift key is used to select multiple items when they appear together in alist and is
utilized by depressngthe shift key and clicking on thefirst and last itemsin the group of items; this
will also select al the items between the two.

These features are used when selecting parameters and/or stations when aggregating and also for

seleding multiplefiles.

7 Sarting GDP in Windows
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3.0 Pull Down Windows

3.1 FileMenu

[EE Data Wiew ‘wWindow
L Mew Chrl+H | ¢
Open... Chil+0 —
F Lloze Fitic
Save Chil+5

Save fz..

1 bob.gdp

Exit

Figure5: File Pull-Down Menu.

3.1.1 New Projects
The New option will create anew GDP project.

3.1.2 Opening Projects
The Open option can be used to open GDP project fileswith a*.gdp extension. To import filesin
another format such as the STORET format use the Data > Add options (see Section 3.2: Data Menu).

3.1.3 Closing aProject

The Close option will close the current project, but the main window and any other projectswill remain
open. If the project has been modified since the last save, you will be asked if you want to save the changes.

314 Saving aProject

There aretwo optionsfor saving projects. The Save option savesthe current project with the current file
name. The file nameisprinted in thetitle bar (i.e. FIETTTDE).

The Save As option can be used to save a project with anew name or location. When thisoption is
selected, awindow is brought up that can be used to specify the name and location of the GDP file. The
Save in field shows the current directory and the File name field is the name of the file you want to save.

9 File Menu
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Save As 21
Save i I 2 enamples j gl
bob.gdp
metalsw. gdp
new.gdp

File name:

new. qdpl Save I
Save as ype: IGDP Filez [*.gdp] j Cancel |

Figure 6: Save As Window

3.1.5 Sedecting Other Projeds
Most recently used projects can be viewed by selecting them from the list displayed above the Exit
optionin the file menu (Figure 7).

Wiew Help
Hew Chil+h
Open... Chil+0 B

1 testl.gdp /
2bobgdp el

3 new.gdp

Recently Used Files

Exit

Figure 7: Selecting Recently Used Projects

3.1.6 Exiting the Project

The Exit option quits GDP. Y ou will be prompted to save any modified projeds. This has the same
effed as pressing the| %| closeiconin the upper corner of the main window.

3.2 DataMenu

<} GDP - GDP1

File View window Help

0O Add STORET or WATSTORE format
Add From Spreadsheet

Figure 8: Data Pull-Down Menu

The Data pull-down menu has the following options:

e Adddatafilesfrom STORET or WATSTORE formats -This option can be used to import datain
standard formats from these data sources. For more information see Section 22.2: Loading
Parameter Data.

» Add data From a Spreadsheet - This option can be used to add data from a spreadsheet program,
when the dataisin the proper format. For more information see Section 32.1: Adding Datafrom a
Spreadshed.

GDP Version 1.1 10



321 Adding Datafrom a Spreadsheet
To use this option, data from a spreadshed program should be saved as a text file with comma or tab

delimiters. The data can also be mpied to your computer’s clipboard using the copy option in the

spreadsheet. Follow these steps to add data from a spreadshed:

1. Credethedatain aspreadsheet according to the following formats:

Pull Down Windows

Single Station - This format uses four columns; identification, value, the time of the reading,
andthe date of the reading. Since the program islooking only at the text, you should be careful
with the formatting of the dates and times. The dates should have the format of Day-Month-
Year or Month/Day/Y ea as shown in Figure 9. Note that all entries use numerical
representations except for Day-Month-Y ear format, which uses the threeletter abbreviation o

the month.

X Microsoft Excel - single_xls

ﬁﬁile Edit Yiew Insert Format Tools Data Window Help 1= =]
DEHERY| 4 2RS|v- - |a®|@ 7
Arial - 10 - B;g|§§|g.&.é.”
D5 | =] 4/11/2000
A T B [ ¢ [ o T E [ F TJo
| 1 |My Stream Flows (cfs) =
| 2 |ID Value  Time Date —
| 3 | 1 20 51500 4/11/2000
| 4 | 2 25 B:15:00 4/11/2000
5 3 3.0 715:00(4/711/20001
6 -
14 [ 4[» [M]"5heet1 / Sheetz £ Sheets /. 4] | LlJJ
Ready[ [ [ [ mM[ [ [ g

Figure 9: Excel File with Single Sation Format

Multiple Stations - Thisformat can include datafrom multiple stations with adate or adate and
atime. To enter atime, enter it in the same cell asthe date & the end and enter it in the format

hour:minute;second.

X Microsoft Excel - multi_xls

ﬁ File Edit Wiew Insert Format Tools Data Window Help =18l x|
D SRY|(sRS o-o- @ = s 8lilj@o -
arial 10 BIQ|EEE|$%,|Ev&v&v ”
He | =[32
A ] B ] ¢ ] D ] E ] F ] 6 | H T3
| 1 |Flow (cfs) 4/11/2000 4/12/2000 4/13/2000 4/14/2000 4/15/2000 4/16/2000 4/17/2000 |
| 2 |Station 1 25 26 27 28 249 3 31
| 3 |Station 2 24 24 24 24 24 24 2.4
iIStation 3 26 27 28 249 3 31 3.2.
= -
14 [4]» [M]sSheet1 / sheetz £ sheets / 4] | LlJJ
Ready 1 o o 0 o

Figure 10: Excd File with Multiple Sation Format

2. Savethe datato the clipbaard using the wpy option or save the data as atext file with columns
delimited by tabs or commeas.

3. Select the Data > Add From Spreadsheet option. The window shown in Figure 11 will be
displayed. Seled the Location, Separator and Format appropriate to the data you are importing.

11

Data Menu
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4. Add the parameter name and units in the Choose Spreadsheet Optionswindow and click on the
Add Parameter button.

Choose Spreadsheet Options x
Chooze Location: Chooze Separator:
’7(" File: « ’7(‘ Comma & Tab

r~ Choose Format: |

= Single station. 1st line is station name; 2nd iz skipped [comment); rest is 4
columns of datar 1D, walue, HH:MM: 55, DaY-MON-YEAR.

Multiple stations. 1st line iz header with first column arbitrary, each
successive column the date of the reading. 1 station per line, 13t colurmn
is station hame, each successive column is a value.

r~ Choose P
Flow [[cfs MNew Parameter:

M ame: IFIow
Urits: I[CfS]

Add Parameter |
()8 I Cancel |

Figure 11: Choose Sporeadsheet Options Window

5. Sdlect the OK button.
6. Sdect the Edit Data tab to view the results. For more information seeSedion 4.3: Edit Data Tab.

3.3 View Pull-Down Menu

: WASP Builder - [WaspB1]

‘Eile WASP BEERE ‘wWindow Help

2 Toolbar
w|r| B[§¥T
v Statuz Bar
—

Figure 12: View Pull-Down Menu

The View pull-down menu has two options, that are toggle switches to change the WASPBuilder
display:
1. View > Toolbar - Thisdisplaysthetool bar with the following options:

=E| 7
New GDP File vy v ) ) S About Box

Open GDP File Save File
Figure 1: GDP Toolbar

New GDP File- Createsanew GDP file, seeSedion 3.1.1: New Projects.

e Open GDP File - Opensa GDP project file, see Sedion 31.2: Opening Projects.
e Save File- Savesthe current projed file, seeSection 3.1.4: Saving a Project.

« About Box - Displays the About GDP dialog (seeSection 3.5.1: GDP Help).

GDP Version 1.1 12
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2. View > Status Bar - The status bar contains information about the workings of the program and
can be displayed or not depending on the setting of the option. It islocated in the lower left corner
of the main window.

| A | - SatusBar

Feady

Figure 2: Status Bar

3.4 Window Pull-Down Menu

& GDP - [GDP1]
File Data iew [f

Mew Window
Lascade

Tile

Armrange lcong

Froject Information | |

Input D ata Files:

pr— 1GDPT

Figure 3: Window Pull-Down Menu
Options for the Window pull-down menu:
1. Window > New Window - This option creates a new view of the current project.

2. Window > Cascade - If there are multiple windows open, this option will cascade the windowsin
the main window.

3. Window > Tile- If there are multiple windows open, this option will tile the windows in the main
window.

4. Window > Arrange | cons - If there are multiple windows iconified, this option will arrange the
iconsin the main window.

Note: Inpu file windows can beiconified, displayed in full-view, or closed using the buttons on the

upper right of each window G . The horizontal line iconifies a window, the sgquare or
doulde square displays the window in full or partial view, respedively and the “ X" symbol
closes the window.

Display of Windows Currently Open - Thelist of windows on the bottom of the Window pull-down
menu displays all the windows that are currently opened. A window can be brought to the front by clicking
on the window in the list. The currently displayed window has a check mark next to it.

3.5 Help Pull-Down Menu

< GDP - [GDP1]

File Data View ‘window [[5e0

JDD”'H|‘?| GDP Help
| About GDP...

Figure 4: Help Pull-Down Menu

13 Window Pull-Down Menu
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35.1 GDPHelp
The WASP Builder help files contain the same information as this document.

35.2 About GDP
About GDP displays the version and date of release for GDP.

GDP Version 1.1 14



Data Tabs

4.0 Data Tabs

GDPisarranged in tabs that can be used to view, edit and process data.

< GDP - [GDP1]

File Data Miew ‘Window Help
D= E|?]

PTUiECHNfUTmatiUn|Aggregation Edit Data | Data Availabilty | Units Page

Figure 13: GDP Data Tabs

4.1 Project Information Tab
This datatab displaysthe full path of any WATSTORE or STORET files the project uses (Figure 14).

File Data View Window Help —21xl
D |2

-
PTUIECHNfUTmaUUn|Aggregation Edit Data | Data Availability UnitsPageI j

Input D ata Files:

I
-
1| | »

Feady ’_ HUM VA

Figure 14: Project Files Data Tab

4.2 Aggregation Tab

This data tab can be used to aggregate or combine stations and parameters for analysis. Data can be
aggregated by:

o Stations- Typicaly locationsfor colleding data.

e Parameters - Types of measurements with values for stations by date and time.

For example, if one of your datafiles contains temperatures for different days but the same location as
another datafile, you can use GDP to combine these two records. Sometimes there are more data sites than
you reed for amodel run, GDP can be used to combine multiple stations to model river reaches. Consider
the possibility that you wanted to treat two STORET stations as the same station. There may be data
collected as part of each of these stations that could provide amore complete record for agiven river reach

15 Project Information Tab
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when combined. This section will walk you through an example of combining two STORET stations
contained in the metalsw.sto file in the Examples directory.

1. Select the File > New option to start anew project

2. Input the STORET datafile (i.e. metalsw.sto) from the Examples directory by using the Data >
Add STORET or WATSTORE format option.

Display the Data Aggregation tab and select the stations option, see Figure 15.

> w

Select the stations or parametersfrom thelist on the left to aggregate. In this case, select item 3and
item 4 from the station list in the left column by clicking on each.

Note - If you need to do a conversion to aggregate parameters, you should go to the Units data tab
and do the conversion before aggregating.

5. Select theright arrow icon 2

6. The Aggregation Name dialog window will be displayed, Figure 15. Give the aggregation a
descriptive name (i.e. New Station) and add the selected stations.

&+ GDP - [GDP1] Ol x]
File Data Miew ‘Window Help -] x|
D |2

Project Information  Agaregation | Edit Datal [rata Availabilityl Units Pagel —

Edit Type |
% Siati CP b >
’7 atons aramerers Agglegallon Name E

Chooze a name for this group:

INew Station

’TI Cancel |
| 4
| | _’ILI
Feady ’_ W ’_ VA

Figure 15: Data Aggregation Tab

Note - If a parameter value occurs at the same time for two stations that are being aggregated, the
average of the two values will be used. Thiswill also be the case when a parameter valueis
calculated over an interval that contains several data points.

7. Toremove station(s) or parameter(s) from the aggregation list box on the right, highlight the new
station or parameter with the cursor and click with the left mouse button on the < button.
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8. Thisprocess can be repeated to crede other aggregates.

Note - Any stations not aggregated will remain unselected in the list of stationsand will retain their
individual data.

9. Thenext step isto seehow the data overl aps from the two stations. The Data Availability datatab
can be used to display and graph the data from the combined stations.

4.3 Edit Data Tab

The Edit datatab can be used to enter values for stations and parameters. Data can viewed and edited
based onstations or parameters using the Edit Type options.

A+ GDP - [GDP1] M=l E3
File Data View Window Help —21xl
D |2
Project Informationl Aggregation  Edit Data | [rata Availability | Unitz Page —
Edit Type
’7(3' Stations £ Parameters
Station | Parameter | Multiplisr | Offset | ;I Add |
CALIFORMIA GULCH AT MaLTA.. TEMPERATURE [wWaTER [DEG.C)] 1 a —
CALIFORMIA GULCH AT MaALTA.. DISCHARGE (IM CUBICFEET PER .. 1 a # 1
000003 LEAD PB_DISS (UGAL) 1 a
0EE93380 WATER TEMP [CENT) 1 a
OEE34400 WATER TEMP [CENT) 1 a LI Delete |
Date | WValue | Scaled Yalue | Mask | ;I
71319910000 18 18 no —
71441991 0000 1.8 18 no
7/15/1991 C:0:0 16 no
7ABM991 000 18 18 no
TATA9SI 000 18 18 no
7819910000 2 2 no
71941991 000 24 24 no
72011991 000 22 22 no LI
Add | # |1 Add From Spreadsheet Set Format Delete |
Ready LM v

Figure 16: Edit Data Tab

Stationsthat have multiple parameterswil | show multipletimesin the Station list with an entry for each
parameter. The parameter associated with the stationin the Station list can be dhanged by pressing the left
mouse button on the correspondng table entry and selecting the new parameter from the Parameter list
dialog (Figure 17). If values are entered before the parameter is changed, the values will be retained with
the new parameter. Therefore, this option should be used with caution.

The entries in the upper tableinclude amultiplier and offset for location-specific conversions. The
station'svalueis first multiplied by the multiplier and then the offset is added; the resultant values are
displayed in the Scaled Value column in the lower table.
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i Choose a Parameter E

LEAD PB_TOT

Cancel |

Figure 17: Choose Parameter in the Edit Data Tab

4.3.1 Adding and Deleting Station-Parameter pairs:
1. Select the number of stationsto add in the field next to the “?” symboal to the right of the upper
display.
2. Select the Add button.
3. New values can be entered in the lower window by typing or by pasting from a spreadsheet.
4, Stations can be deleted by pressing the Delete button and choosing them from the dialog that pops

up. This option shoud be used with caution since it can not be undore.

4.3.2 Adding Valuesfor Parameters
Values can be entered by typing them into the bottom table or from a spreadsheet.

1. First select the station and parameter pair from the upper table that youwant to add valuesto. If you
want to add the values by hand, enter the number to add in the upper table and pressthe Add button
on the bottom of the window. New value place holders will be added at the end d the parameter
list. The value will be zro and the date will based either on the current time or the date of the last
entry. Edit the date and values by seleding the table cells and typing in the new values.

2. If you have datain a spreadsheet, set the format of the data to be pasted from the spreadshee by
seleding the Format button.

Parse Spreadsheet Information [ %]
The first five columns of each line has the following form:

| MM/DD /YTy HH:MM:SE 7 | [viaLUE =lfskiP =l|ske =|fskiP 4|

()8 I Cancel |

WALUE
MDD T HH M55
MDD T HH M
MMDDATY T

HH:MM:55

HH:Mt

SKIP

WALUE

MDD T HH M55
MMDOAN T HHo MM

Figure 18: Format of Spreadsheet Data

Each dof thefieldsin the Par se Spreadsheet | nfor mation window correspondsto a amlumn of data
that is separated bytabs. Once the format corresponds to the data you are copying from a
spreadsheet seled the OK button.
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3. Make surethe datato be pasted from the spreadsheet isin the arrect format. Seled the data
columns and the Edit > Copy command in the spreadsheet program. The datawill be saved to your
computer’s clipboard.

4. Sedlect the Add from Spreadsheet button and the datawill be added to the lower datatable for the
station and parameter combination selected.

4.4 Data Availability Tab

Thistab isused to plot graphs that show data availability, data values, and to export data. Data
availability plotsare typically used before data aggregation occurs to determine appropriate station and/or
parameter aggregation (see Sedion 4.4: Data Availability Tab). Thistab can aso be used to view theresults
of adata aggregation and to export aggregated data to other programs.

#+ GDP - [GDP1] IH[=] B3
File Data View Window Help —21xl
0=
CIkd L. Data Type
Project Information | & tion | Edit Data Data Availability | Urits P =
. roject Information I Jgregation I [l ata | hits Fage I /_/. Graph
gat-a ;Ij-lme Start: IJan =l |1 =l |1994 - - Data Type———— Button
erio —_—] " Data Awvailability
End [Dec =[5 =] [195 = By B _|\~—. Export
Main List — _ % DataValues
an IS// Main list consists of. (% Stations  Parameters Button
Setting Stations Parameters — Plat Style — Diata Interval
. CALIFORNIA GULCH AT a] [WATER TEMF & MasheanMi Plot Style
Station and 00003 B -~ axtfieantin Evey [l ~— |
I |oe6s3s80 Mean H .
Parameter 05634400 . l”— [Months | Date
List 0ERI4700 ™ Add threshold line at: Inte rVal
. |U?U?92DD I~ Fill missing data using interpolati
Data DlSplay Draraa0n LI ill mizzing data uzing interpolation - |nterp0|ate
\ Data for parameter STREAM FLOW_ Optlon
Station | 141994 | 211994 | 311994 | 441994 | 541994 | 641994 | 711994 | &
07079195 7 5 - - 12 140 405 20
< | ]
Feady HUM A

Figure 19: Data Availability Tab

441 DaaTime Period

The datatime periodis defined by the Start and End dates. The default start date is the date of the
earliest record that appearsin any of the selected datafiles. Similarly, the default end dbte is date of the last
record. Y ou can shorten the period d record by setting new valuesfor the start or end date. Y ou can adjust
the start and end dates by selectingthe new year, month, and day in the scroll liststo theright of the display.

19 Data Availability Tab
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Praject Informationl Aggregationl Edit Data Data Availability |
Stat: Jdan |1 x| Jims 7]
| R I EEES =l

i+ Stations

£ Parameters

Parameters

Figure 20: Scrall List for Data Time Periods

4.4.2 Main List Setting

Thisoption is used to switch the order of the Station and Parameter lists, so that data can be viewed
by looking at one parameter at several stations or by looking at several parameters for one station. Theright
list allowsfor only one selection, and the list on the left allows for multiple seledions.

44.3 Station and Parameter Lists

Thisisalist of al the stations available, if the Stations option is selected for the Main List Setting.
Theright list will show all the parameters that are associated with the selected stations. The order can be
reversed by selecting the Par ameter s radio button. If youwant to make multiple selections for parameters
or stations make sure that the groupisin the display on the left.

444 DataDisplay
Datafor the seleded stations and parameterswill bedisplayed in thisarea. The datadisplayed here will
be the same data that is used for the graph and export options.

445 DaaType

Shows data availability or data values for the selected stations and parameters. When the Data
Availability option is ®lected, time periods that have areading for the selected items will show avalue of
1, and periods without datawill show a0 in the Data Display.

« DataAvailability - Displays symbadlsfor the dates when thereis adatareading for the given station
and parameter.

« Data Values - Displays the data values for the parameter specified. This option can ony be used
for single-parameter selections.

4.4.6 Graph Button

Graphsthe datadisplayedinthelower table. Thedata avail ability graphwill list the station a parameter
names on the left y-axis and use a symbal to indicate if datais avail able for the period of record that you
regquested. Otherwise values of agiven parameter are on the y-axis and the period of record isonthe x-axis
on the plots. The plot graph window (Figure 21) is displayed when the Graph button is selected from the
Data Availability tab.
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' STREAM FLOW_
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Figure 21: Plot Graph Window

Note- The graph format can be changed using options in the graph control tabs. For more
information on how to use these options, select the help button in the Graph window by
clicking on the il icon.

4.4.7 Export Button

This option generates a simple report using the contents of the data table. When the Export button is
seleded, the Export Options window will be displayed.

Export Report Table Options [ %]

£ Ta file, tab-delirmited
£ Ta file, comma-delimited
WASP helpers:

£ Tafile, a3 timessries

" Toclipboard, as timeseries

()8 I Cancel

Figure 22: Export Report Table Options
The Export Report Table has the following options:

» Toclipboard - Thisoption saves the informationin the data display to the dipboard usingtabs for

delimiters. The information can then be pasted into a spreadsheet using the File > Paste option
within the spreadsheet.

Tofile, tab-ddimited or comma delimited - These options bring up afile browser window to
specify the name and location o the ASCII datafile.

WASP Helpers- These options can be used in conjunction with WA SP Builder to populated input
datafiles for the WA SP water quality model.
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4.8 Exporting Datafor WASP
To use these option you should have only one station selected. If you have multiple stations selected, a
warning box will appea.
GDP E

& Only timeseries data for a single station and parameter can be output.

Figure 23: WASP Warning Box

The data can be saved to your computer’s clipboard and then pasted drectly in the correct datatab in
WASPBLUIilder, or it can be saved to afile to be imported later. The file option will display afile browser
window to specify the name and locaion o the fileto be saved.

Note - To paste or import the file into Wasp Builder see the Wasp Builder User Manual for how to
import timeseries data.

449 PlotStyle

This option can be used to plot the data in a graph with different styles. The maximum, mean and
minimum of thevaluesin the selected period of record usingthe Date I nterval will be displayed if the M ax-
Mean-Min radio buttonis seleded. Otherwise the table entries will represent the mean of the data.

Note- All Plot Style options are active only when the Data Values option is set in the Data Type.

The following qotions are available for plot style:

e Max-Mean-Min - Thisoption plots the maximum, mean, and minimum of the data seleded.

* Mean - This option displays the mean of the data seleded for the selected interval.

» Addthreshold lineat: - Thisoptionwill display aline onthe plot at the value entered in the field.

4.4.10 Date Interval

Data can be displayed using dfferent intervals of time. For example, a data reading can be generated
for every 10 yeas darting at the date given in the Start: fields by spedfyinga“10” inthe Every field and
seleding year sfrom the scroll list. If multiple data points fall in agiven interval, the value generated isthe
average of the data points.

4.4.11 |nterpolate Option

The Interpolate option can be used to fill in missing data. The dgorithm fills the beginning andend o
the period selected with the first and last values, respedively. For every additional missing value a linear
interpolation is done between the nearest values on either side. For exampleif you had the following data:
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My Stream Flows (cfs)
ID Value Date

1 - 4/10/2000
2 2.0 4/11/2000
3 -—= 4/12/2000
4 3.0 4/13/2000
5 -—- 4/14/2000

Thevaluefor ID #1would be 2.0 and 30 for ID #5, the values of I D #2 and #4repeated, respectively.
Thevauefor ID #3is halfway between the values for ID #2 and #4, so therefore 2.5.

45 UnitsPage Tab

A+ GDP - [GDP1] M=l E3
File Data View Window Help —21xl
D |2
Project Informationl Aggregationl Edit Datal Diata &vailabilty  Units Page | —
Units for all parameters in project
Description | tultiplier | Offset | Alias | Comment
INST-CFS 2 a INST-CFS INST-CFS
CENT 1 a CENT CENT
FEET 1 a FEET FEET
UG 1 a UG UG
r Standard conversion
Conversion Mame | tultiplier | Offset |
[C-:]F 18 32
[F->]C 0.5555 17.78 Add
a
Delete

Apply <new entry> conversion to INST-CFS

=]
Feady ’_WI_ VA

Figure 24: Units Conversion Window

The Units Page tab alows you to convert a parameter’s units to another type using a pre-defined
conversion equation or by defining you own conversion equation. All the units used for your projed are
displayed in the upper table. The lower table can be used to crede standard conversions you may want to
use for other projects. For example, Centigrade to Fahrenheit is already provided. When a standard
conversion iscreaed, it is saved in a separate program file and will be read by successive projects.

Conversions use amultiplier (i.e. the slope of the relationship) and an offset (i.e. the y-intercept value)
alowing for complex unit conversions. The multiplier is multiplied timesthe original values and the offset
is added to the result for every place in the project the units are used.
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5.0 Input File Formats

Input filescan bein standard STORET or WATSTORE fileformats. This section providesadescription
of the file formats supported by GDP. Data can also be entered into GDP using a spreadsheet program; the
formats used are described in Section 3.2.1: Adding Data from a Spreadsheet and Section 4.3.2: Adding
Vauesfor Parameters.

5.1 STORET File Format

STORET retrievalsfor water quality datainclude a string indicating the date, time and station name and
columns for each parameter with values.

00003 00010 00061 00003 00010 01051 01049 01055 01056 01045
VSAMPLOC WATER ~ STREAM VSAMPLOC WATER LEAD LEAD MANGNESEMANGNESE  IRON
DEPTH TEMP FLOW_ DEPTH TEMP  PB_TOT PB_DISS MN MN_DISS FE_TOT

FEET CENT INST-CFS FEET CENT UG/L ug/L ug/L ug/L uG/L

19730809-999126901 -9 7.0 -9 -9 7.0 -9 -9 -9 9 9
199004181245390009106135001 -9 5.5 -9 -9 5.5 -9 -9 -9 9 9
199006061405390009106135001 -9 8.5 84 -9 8.5 -9 -9 -9 9 9
199007171840390009106135001 -9 12.5 27 -9 12.5 -9 -9 -9 9 9
199008281620390009106135001 -9 13.5 13 -9 13.5 -9 -9 -9 9 9
199010310800390009106135001 -9 1.5 7 -9 1.5 -9 -9 -9 9 9
199104240835390009106135001 -9 1.5 3 -9 1.5 -9 -9 -9 9 9

The secondline of thefileisthe parameter names garting at column 26 at each 8 character spaces. The
third lineisthe continued name of the parameter andisread in the same manner. Thefourth lineisthe Units
for the parameter is real in the same way. Successve lines are read for the yea first (4 digits), and the
month, day, hour, and minutes all 2 digits each. The parameters are read with the value occurring after at
least one space. Non-values are stored as “-9”
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5.2 WATSTORE File For mat

WATSTORE retrieval files typically contain all the details of the data query including the cost, what
parameters were found, etc. Next, the datafollows listed by station with the parameter values for each date

in atable format.

1 UNITED STATES DEPARTMENT OF INTERIOR - GEOLOGICAL SURVEY PROCESS DATE IS 08-30-96
0 STATION NUMBER 07081800 CALIFORNIA GULCH AT MALTA, CO. STREAM  SOURCE AGENCY USGS
LATITUDE 391321 LONGITUDE 1062117 DRAINAGE AREA DATUM STATE 08 COUNTY 065

DISCHARGE, IN CUBIC FEET PER SECOND, WATER YEAR OCTOBER 1991 TO SEPTEMBER 1992
MEAN VALUES

0 DAY ocT NOV DEC JAN FEB MAR APR MAY JUN JUL AUG SEP
1 1.5 1.0 1.0 1.1 1.3 1.6 1.4 1.7 1.5 .89 1.3 2.4
2 1.3 1.0 1.1 1.1 1.3 1.7 1.5 1.7 1.6 .96 1.4 2.5
3 .93 1.0 1.2 1.0 1.3 1.5 1.6 1.5 1.5 1.1 1.0 2.4

GDP looks for the “un1TeD STATES DEPARTMENT OF INTERIOR - GEOLOGICAL SURVEY” text to know when to start
reading datafor astation. The next lineincludesthe station number and reme, which isread and stored. The
next two lines are skipped and the parameter, units and period d record are read. The dataiis stored by day
of the month with the months listed by water yea (i.e. October - September). The datais storedin 9
charader strings starting at the 20th character. Thisinformation is stored for each of the 31 days of the
month. After the first set of data values are read, the dgorithm searches for the next header string and the
next set of values. Non-values are stored using “---".
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